"Do not store entries" being ignored for a form

By: Dana Whittle | Asked: 12/30/2022
ForumsCategory: General questions"Do not store entries" being ignored for a form
Dana WhittleDana Whittle asked 1 year ago
I have a form set up to allow front-end updating of custom fields (via ACF) for Users registered via Formidable. I have checked "Do not store entries submitted from this form" yet, when I update my User profile via this form, it creates an entry. The fields in this front-end edited form are successfully updated (they are synced with user_meta key=custom_field). Has anybody else experienced (or fixed) this issue?
Attachments
2 Answers
Victor Font answered 1 year ago
I wouldn't call this a bug. With user registration, user user meta data is written to the WordPress user tables after an entry is created or updated. Those are the settings in the user registration add-on. The add-on is probably overriding the the other setting. If you believe this is a bug, open a ticket with Strategy 11 support.
Dana WhittleDana Whittle replied 1 year ago

Thanks - it just seems weird to have this be an option. The form is "updating" an existing entry, not creating a new one.

Victor Font replied 1 year ago

You can't update an existing entry if you never saved the entry in the first place. There would be no link between Formidable and the user record. As I mentioned earlier, if you believe you've uncovered a bug, open a ticket with the Formidable Support team. This is a community form where questions are answered by volunteers. We have no affiliation with Strategy 11 and can't help with bugs.

Allen Langford answered 1 year ago

I am experiencing the same or similar issue on 02/08/2023. My form is not suppose to store ANY entries. Now, no matter what I enter into the form it gives the message, "We're sorry. It looks like you've already submitted that."  Even if I clear out ALL ENTRIES for this form, which never should have been there and never were previously, the very first time I enter ANY data and submit it, I get the same message. The Form was working fine just minutes before, capturing information and passing to PHP script and NOT STORING anything.This is an old form (1+ years) that we use for testing. I had the "Do not store" checkbox checked. I use the same test data over and over with no issue. Never an issue in entering the data over and over again to test a backend process. It is NOT a caching issue. Cleared all cache at server and browser level.What changed? I had a Google reCaptcha field on the form and it started getting errors, as a number of our websites have recently with reCaptcha, so I removed the reCaptcha from from the form and "updated" the form. I also turned on/off the Honeypot "Strict" option. As well as checked the box for "Check entries for spam using Javascript".  I don't know if any of these created the problem but now I cannot use the form at all because I cannot get past the error message.Potential Causes?- It is an old form (1+ years). It was backward compatible with new releases perhaps as long as I did not change anything or "Update" it. There are numerous additions and changes that have been made since the form was created.- Removing reCaptcha from a form could have caused an issue.

Years ago I had a problem with Formidable Forms creating duplicate entries on every stored entry. Formidable provided some PHP code I had to add to our WordPress theme to prevent this from happening. Just maybe that bug has resurfaced and my code no longer works under certain circumstances. Not sure. It's just grasping at straws now.The only real resolution it appears is to try and recreate the entire form and see if it will work being created using the latest release. If anyone has a solution or has experienced the same type of situation, I'd love to hear about it.

Making the Best WordPress Plugin even better - Together

Take on bigger projects with confidence knowing you have access to an entire community of Formidable Experts and Professionals who have your back when the going gets tough. You got this!
Join the community
crossarrow-right