Edit Links not displaying for some entries

By: shaun haage | Asked: 10/30/2023
ForumsCategory: General questionsEdit Links not displaying for some entries
shaun haage asked 6 months ago
Hi, Very strange, some of the edit links are not displaying on my view. Some entries automatically display and others dont. I have if I force a value to load the edit page, the form fields are blank, however, if I check entries on the backend they are populated. The view itself does not contain any filters or sorts.  Any idea what could be causing this? Thanks
1 Answers
Rob LeVineRob LeVine answered 6 months ago
My guess is that it has something to do with form permissions, especially where the form fields are blank, because that means it can't bring up an editable version of the entry, so it displays a "new entry". See https://formidableforms.com/knowledgebase/set-up-front-end-editing/
shaun haage replied 6 months ago

Rob, I have updated the permissions to allow front end editting, however my workflow is as a such. A user submits a warranty application on the front end of our site. This entry then rolls up into a form view that an adminsitrator of our site only has access to. They can then update the form and apply a signature. This field is only available to the adminstror. In practice this should be working as exected, but somehow not. consistently. I have found that if I submit the applicaton form as an admin, the edit button shows. If I submit as an non-logged in user, the edit button doesnt work, Any thoughts?

Rob LeVineRob LeVine replied 6 months ago

Maybe someone else can help, but I won't be able to debug without a hands-on look at it.

Making the Best WordPress Plugin even better - Together

Take on bigger projects with confidence knowing you have access to an entire community of Formidable Experts and Professionals who have your back when the going gets tough. You got this!
Join the community
crossarrow-right