Form not working on mobile

By: Tharini Rouwette | Asked: 05/14/2023
ForumsCategory: General questionsForm not working on mobile
Tharini Rouwette asked 11 months ago

My form only seems to register applications made via laptop/desktop but doesn't take in those made via  mobile phone. Because of this issue, I have now missed many more registrants who have applied and I have no way of contacting them. How do I fix this issue asap?

Victor Font replied 11 months ago

I've never experienced a problem with forms not working on mobile devices and I have a lot of questions:

What kind of mobile device are you using?
What's the mobile OS?
Did you test your form on mobile devices before deploying to production?
How do you know that you're missing "many more registrants" if the form's not working and you can't count them? How are you determining this metric?
Is your Formidable license and software up to date?
Have you updated the software to their latest versions?
What version of PHP are you running?
Are you using AMP plugins that disable JavaScript on mobile devices?
Are the forms being cached?

There are a lot of diagnostics that need to take place. If this were a problem with Formidable, more people would post about it. Yours is the first post I've ever seen about a form not working on a mobile device. This suggests there's a problem or misconfiguration somewhere with your system. I'm not sure we can help you further as community volunteers.

If you need a developer's help, please visit https://formidable-masterminds.com/developers-directory/ to retrieve a list of some of the top Formidable developers in the community.

1 Answers
Maio Rosatzin answered 10 months ago

Hi, I came across this question and would like to get in touch as well. I currently have a similar problem with a form. It's a lookup form that I use to filter a views entry, it's about 6 fields that build on each other.  On desktop everything works great, but on mobile devices only the first lookup field works, the second one doesn't show the Lookup Options anymore.  I have already tried several browsers and prevented this page from being cached. My Formidable Version is the Newest Possible and there should not be a Problem with my API Key. by the way i use an Apache version 8.2 and the newest Wordpress.  How could i solve this Problem?

Incase you want to check it for yourselve: here is my URL: Wertermittlung - Gentleman-watches(Currently only in German) Thank for the Support

Maio Rosatzin replied 10 months ago

I just solves the Problem, looks like taking the check box of of " Auf Optionen beschränken, welche vom aktuellen Benutzer erstellt wurden (Translated in English:Restrict to options created by the current user) " solved the Problem.

This box is in the Forms setting, under the Lookup Setting, bellow Filter by lookup fields.

Hope this Helpes

Maio Rosatzin replied 10 months ago

I just solves the Problem, looks like taking the check box of of " Auf Optionen beschränken, welche vom aktuellen Benutzer erstellt wurden (Translated in English:Restrict to options created by the current user) " solved the Problem.

This box is in the Forms setting, under the Lookup Setting, bellow Filter by lookup fields.

Hope this Helpes

Kris Peleman replied 9 months ago

Hi,
I'm dealing with the same problem on https://www.metmoedvooruitopdorp.be/mosselfestijn/. The number field should be invisible until you select a products (Checkboxes Field). On desktop it works fine, but not on mobile. On mobile is the number field always visible and the total box (a textfield with proper calculation) doesn't count.
Very strange. Maybe you can help me?

Making the Best WordPress Plugin even better - Together

Take on bigger projects with confidence knowing you have access to an entire community of Formidable Experts and Professionals who have your back when the going gets tough. You got this!
Join the community
crossarrow-right